Загрузка программ на нескольких роботов ТРИК из Sublime и VSCode

В данной статье рассматривается возможность одновременной загрузки программ на группу роботов с использованием внешних текстовых редакторов Sublime и VSCode. Статья является продолжением материалов о том, как использовать профессиональные внешние редакторы Sublime и VSCode для разработки программ для контроллера ТРИК и запуска их в TRIK Studio.

Настройка

Скачайте файл send_files.cmd для Windows и поместите его в папку, в которую установлена TRIK Studio.

Для Sublime Text

Инструкция протестирована на Sublime Text 3 (Build 3211), версия от 06.02.20
Перед первым запуском программы необходимо зайти на контроллер ТРИК через WinSCP. Инструкция о том, как это сделать, доступна по ссылке. После этого WinSCP запомнит, что было разрешено устанавливать соединение с этим роботом и не будет требовать подтверждений. Это действие необходимо повторять при подключении каждого нового контроллера.
1
Откройте Sublime Text.
2
Выберите Tools → Build System → New Build System.
3
Откроется окно с текстовым файлом. В нем необходимо всё стереть и вставить вместо этого следующий код:
{
"cmd": ["D:\\TRIKStudio\\send_filesl.cmd", “<path to scripts dir>”, "<file with ip addresses>"],
"selector": "source.js"
}
Здесь:
  • <path to scripts dir> — полный путь к папке с программами, которые хотим загрузить на роботов,
  • <file with ip addresses> — название файла .txt, в котором содержатся ip-адреса роботов, на которые необходимо загрузить файлы (каждый ip адрес на новой строке). Файл с ip-адресами роботов должен находиться в той же папке, что и отправляемые программы.
4
Укажите свой путь к файлу send_files.cmd вместо указанного в коде. Например:
"cmd": ["C:\\TRIKStudio\\send_files.cmd", "C:\\Users\\Admin\\myfiles", "ip_addr.txt"]
5
Сохраните этот текстовый файл в предлагаемой директории <папка с системными файлами>\Sublime Text 3\Packages\User под именем TRIK_SEND.sublime-build.
6
Выберите Tools → Build System и в открывшемся списке выберете TRIK_send.
7
Для начала отправки программ на роботов достаточно нажать Tools → Build или соответствующую комбинацию клавиш Ctrl+B. Для того чтобы вернуться к запуску 2D-модели, необходимо выбрать Tools → Build System и в открывшемся списке выбрать TRIK.

Для VSCode

Инструкция протестирована на январском релизе 2020 года (version 1.42). Версия на 6.03.20
При первом запуске программы для установки соединения с роботом потребуется подтверждение от пользователя.
Чтобы разрешить соединение, введите в командной строке Y или Yes.
1
Откройте папку с файлами, которые хотите отправить, в VSCode с помощью File → Open Folder.
2
Вызовите Terminal → Configure Tasks.
3
Если ранее задач не было, то выберите в выпадающем меню Create tasks.json file from template → Others. Откроется файл tasks.json. Если tasks были созданы ранее, он откроется сразу после пункта 2.
4
Удалите всё из этого файла и вставьте данный код:
{
    "version": "2.0.0",
        "tasks": [ {
            "label": "Send files",
            "type": "shell",
            "windows": {
                "command": "C:\\TRIKStudio\\send_files.cmd  <path to scripts dir> <file with ip addresses>"
            },
            "group": "test",
            "presentation": {
                "reveal": "always",
                "panel": "new"
            }
        }]
}
Здесь:
  • <path to scripts dir> — полный путь к папке с программами, которые необходимо загрузить на роботов,
  • <file with ip addresses> — название файла .txt, в котором содержатся ip-адреса роботов, на которые хотим загрузить файлы (каждый ip-адрес на новой строке).
5
В строке, соответствующей полю "windows": { "command" укажите путь к файлу send_files.cmd. Файл с ip-адресами роботов должен находиться в той же папке, что и отправляемые программы. Например:
"command": "C:\TRIKStudio\send_files.cmd C:\Users\Admin\myfiles ip_addr.txt"
6
Сохраните файл tasks.json.
7
Теперь при нажатии Terminal → Run Task в выпадающем меню выбираем Send files, чтобы загрузить программы на роботов, или соответствующую комбинацию клавиш Ctrl+Shift+B.