Интерфейс TRIK Studio

Среда TRIK Studio может работать в двух режимах:
Предназначен для создания диаграммы управления роботом и исполнения её на роботе в режиме генерации.
Предназначен для исполнения и отладки программы на двумерной модели или в режиме интерпретации на реальном роботе.

Режим редактирования

Окно редактора (сцена)

Сцена отображает диаграмму и позволяет ее редактировать. Здесь же осуществляется отображение текущего исполняемого блока при интерпретации диаграмм.

Главное меню

Главное меню содержит набор базовых операций и настроек среды.
Файл
  • Новый проект — создать новый проект.
  • Недавние проекты… — открыть один из недавно использовавшихся проектов.
  • Новая диаграмма — создать новую диаграмму в текущем проекте.
  • Открыть… — открыть сохраненный проект. Проекты хранятся на диске в файлах с расширением *.qrs.
  • Сохранить — сохранить текущий проект.
  • Сохранить как… — сохранить текущий проект в выбранное местоположение. Последующие сохранения будут производиться в выбранный файл.
  • Сохранить диаграмму как картинку… — сохранить на диск текущее изображение на сцене.
  • Печать — распечатать диаграмму или текст, используя стандартный диалог печати.
  • Выход — выйти из программы.

Правка

  • Отменить — отменить выполненное действие.
  • Повторить — сделать снова отмененное действие.
  • Копировать — копировать выбранный элемент.
  • Вставить — вставить выбранный элемент.
  • Вырезать — вырезать выбранный элемент.
  • Найти... — открыть диалог поиска по проекту.

Вид

  • Приблизить — увеличить масштаб сцены.
  • Отдалить — уменьшить масштаб сцены.
  • Панели — включить / выключить отображение различных плавающих окон.
  • На главную — вернуться на главную.

Инструменты

Внимание! Пункты в этом меню могут появляться и исчезать в зависимости от конфигурации программы.
  • Жесты мышью — открыть вкладку со списком доступных жестов мышью.
  • Выполнить — запустить выполнение отображаемой в данный момент диаграммы на роботе в режиме интерпретации. (Пункт показывается только в режиме интерпретации.)
  • 2D модель — переключить режим работы интерпретатора на двумерную модель.
  • Реальный робот — переключить режим работы интерпретатора на управление реальным роботом по Wi-Fi, Bluetooth или USB в зависимости от используемого конструктора и настроек соединения с роботом.
  • Настройки — открыть окно настройки модели робота, с которой осуществляется работа в TRIK Studio.
  • Сохранить как упражнение… — сохранить текущую диаграмму и двумерную модель как упражнение для учащихся. В упражнении нельзя модифицировать некоторые части решения. Например, расположение объектов в двумерной модели или конфигурацию датчиков. Выбор этого пункта меню открывает диалог, в котором можно выбрать фиксируемые части. (Подробнее про упражнения.)
  • Загрузить системное ПО на робот — загрузить на робота прошивку, позволяющую выполнять загруженные в него программы. Обычно этого делать не требуется или требуется сделать только один раз перед началом работы.
  • Генерировать код — открыть вкладку со сгенерированным кодом, соответствующим текущей диаграмме и выбранному текстовому языку (этот пункт может выглядеть как «Генерировать код на JavaScript», «Генерировать код на F#», «Генерировать код на C» и т. д.). Код не загружается на робот и не исполняется, но может быть отредактирован и загружен позже.
  • Загрузить программу — только сгенерировать код и загрузить на робот, не исполняя его.
  • Загрузить и выполнить программу — сгенерировать код, соответствующий текущей диаграмме, загрузить его и исполнить на роботе.
  • Остановить робота — прервать выполнение программы и послать роботу команды отключения моторов.
  • Подключиться — установить соединение с роботом. Робот должен быть включен. Показывается только в том случае, если выбранный режим работы с роботом предполагает необходимость постоянного подключения (например, интерпретация программы по Bluetooth или Wi-Fi).

Настройки

Подробнее см. в разделе «Настройки среды TRIK Studio».
  • Настройки — открыть окно настроек среды TRIK Studio.
  • Показать сетку — включить / отключить отображение сетки на сцене.
  • Показать направляющие — включить / отключить режим отображения вертикальных и горизонтальных направляющих линий для позиционирования объектов относительно друг друга.
  • Включить сетку — включить / отключить режим автоматического выравнивания по сетке.
  • Включить направляющие — включить / отключить режим вертикальных и горизонтальных направляющих линий для позиционирования блоков относительно друг друга.
  • Показать весь текст — включить / отключить отображение всех свойств блока прямо на диаграмме. Если текст под блоками отключён, свойства можно просматривать и редактировать в редакторе свойств слева вверху.

Справка

  • Помощь — открыть справку.
  • О программе — просмотреть краткую информацию о TRIK Studio.
  • Проверить на наличие обновлений — получить из интернета информацию о наличии новой версии среды или какого-либо из подключаемых модулей и запустить при необходимости автообновление.

Панель «Файл»

Панель «Файл» повторяет основные операции, доступные из меню «Файл».

Создать новый проект.

Открыть сохраненный проект.

Сохранить текущий проект.

Панель «Правка»


Отмена операции.

Повтор операции.

Панель «Вид»

Панель «Вид» содержит кнопки, позволяющие масштабировать диаграммы. Этого же можно добиться вращением колесика мыши, наведя курсор на произвольное место рабочей области диаграммы.
Приблизить / отдалить.

Панель «Интерпретатор»

Панель «Интерпретатор» содержит команды запуска и остановки выполнения программы, кнопки переключения режимов интерпретации между двумерной моделью и реальным роботом, а также кнопку открытия настроек робота, доступных из меню «Инструменты». При работе с реальным роботом в режиме интерпретации эта панель также содержит кнопку «Подключиться».

Запуск выполнения программы.

Остановка выполнения программы.

Двумерная модель.

Реальный робот.

Настройки робота.

Панель «Генераторы»

Внимание! Команды на этой панели изменяются в зависимости от конфигурации программы.
Панель «Генераторы» содержит команды генерации кода и загрузки программы на контроллер.

Генерировать код.

Загрузить программу.

Панель «Прочее»

Панель «Прочее» может содержать различную информацию в зависимости от выбранной платформы.

Например, для конструктора ТРИК на данной панели отображается ip-адрес контроллера, к которому вы подключаетесь.

Панель переключения режимов редактирования и отладки

Панель переключения режимов отображает текущий режим TRIK Studio и позволяет переключаться между режимами редактирования и отладки.

Редактор.

Отладка.

Панель «Редактор свойств»

Редактор свойств используется для отображения и редактирования значений свойств выделенных объектов (блоков, связей). О работе с редактором см. раздел «Редактирование свойств элементов».

Панель «Настройки сенсоров»

Настройки сенсоров позволяют указать, какие сенсоры использованы на каком порту. То же можно сделать из диалога настроек робота.

Набор сенсоров зависит от выбранной платформы в меню «Настройки» на вкладке «Роботы».

Панель «Палитра»

Палитра элементов содержит набор доступных блоков и связей между ними, которые можно добавить на диаграмму (подробнее о процессе создания диаграмм и добавлении блоков на сцену в TRIK Studio см. разделы «Создание диаграмм» и «Создание и удаление блоков»). Состав палитры может меняться в зависимости от выбранной в настройках платформы. Серым выделены блоки, недоступные в выбранной модели выполнения (двумерной модели или на реальном роботе).

Панель «Переменные»

Список переменных, используемых при выполнении диаграммы с их текущими значениями, включая сенсорные переменные. При исполнении в режиме интерпретации на двумерной модели или реальном роботе берутся с робота в реальном времени. В режиме генерации не используются.

Строка статуса

Строка статуса отображает текущий режим TRIK Studio (редактирования или отладки) и позволяет переключаться между режимами. Для переключения достаточно кликнуть на кнопку статуса.

Режим отладки

В режиме отладки главное меню, панели инструментов и строка статуса такие же, как в режиме редактирования.

Окно «Двумерная модель»

Окно «Двумерная модель» открывается, если в качестве режима исполнения программы выбрана двумерная модель. Окно позволяет задать окружение, в котором будет работать робот, задать датчики робота и наблюдать, как будет работать написанная в режиме редактирования программа. (Подробнее об окне двумерной модели.)

В режиме интерпретации программы на реальном роботе по Wi-Fi, Bluetooth или USB это окно не показывается, вместо него отображается исполняемая диаграмма.

Окно «Ошибки»

В случае синтаксических и семантических ошибок сообщения о них при попытке выполнения программы появляются в информационном окне «Ошибки». При этом выделяется блок, где появилась ошибка, и указывается позиция ошибки внутри выражения.

Панель «Графики»

Окно «Графики» отображает в реальном времени значения, присылаемые датчиками. Подробнее см. в соответствующем разделе.