Вызов 2D-модели из внешних текстовых редакторов
(VSCode, Sublime)

В данной статье рассматривается настройка и использование внешних сред программирования текстовых языков (в частности, Sublime и VSCode) для вызова программ в 2D-модели TRIK Studio. Это позволит опытным пользователям TRIK Studio использовать все возможности профессиональных текстовых редакторов и их плагинов: статические анализаторы, автоформаттеры, цветовые темы. Также рассказывается как автоматически запускать программу на нескольких полях, что может быть полезно участникам соревнований с автоматизированными системами проверки, например, Олимпиады НТИ ИРС.
За активную помощь и участие в обсуждении данной функциональности команда проекта ТРИК благодарит участника Олимпиады НТИ ИРС 2018—2020 гг. Александра Журавлева.

Настройка

Предполагается, что пользователь пишет программу во внешнем редакторе и хотел бы запустить данную программу на одном или нескольких полях. Поля могут быть представлены как в формате .xml (подробнее в статье «Гибкая настройка 2D-модели»), так и в формате .qrs.
  1. Cкачайте файл run_2d_model.cmd для Windows или run_2d_model.sh для Linux и поместите его в папку, в которой установлена TRIK Studio.
  2. Поместите поля, на которых необходимо тестировать программу, в отдельную папку. Если поля представлены в формате xml, создайте в данной папке пустой проект defualt.qrs.

Для Sublime Text

Инструкция протестирована на Sublime Text 3 (Build 3211), версия от 06.02.20
1
Откройте Sublime Text.
2
Выберите Tools → Build System → New Build System.
3
Откроется окно с текстовым файлом. В нем необходимо всё стереть и вставить вместо этого следующий код, где <path to field dir> полный путь к папке с полями:
{
"cmd": ["D:\\TRIKStudio\\run_2d_model.cmd", “<path to fields dir>”, "$file"],
"selector": "source.js",
"encoding": "windows-1251"
}
4
В зависимости от вашей операционной системы отредактируйте этот файл:
  • Для Linux необходимо подставить свой путь к файлу run_2d_model.sh вместо указанного в коде. Например:
    "cmd": ["/home/admin/TRIKStudio/run_2d_model.sh", "/home/admin/fields/", "$file"],
  • Для Windows необходимо подставить свой путь к файлу run_2d_model.cmd вместо указанного в коде. Например:
    "cmd": ["D:\\TRIKStudio\\run_2d_model.cmd", "D:\\Users\\Admin\\fields", "$file"],
5
Сохраните этот текстовый файл в предлагаемой директории (<папка с системными файлами>\Sublime Text 3\Packages\User) под именем TRIK.sublime-build.
6
Откройте ваш исходный JavaScript-код в Sublime Text. Для его запуска достаточно нажать Tools → Build или соответствующую комбинацию клавиш (Ctrl+B).

Для VSCode

Инструкция протестирована на январском релизе 2020 года (version 1.42). Версия на 6.07.20
1
Создайте папку, в которой будет находиться файл с исходным JavaScript-кодом.
2
Откройте эту папку в VSCode c помощью File → Open Folder.
3
Вызовите Terminal → Configure Tasks.
4
Если ранее задач не было, то выберите в выпадающем меню Create tasks.json file from template → Others. Откроется файл tasks.json. (Если tasks были созданы ранее, он откроется сразу после пункта 3).
5
Удалите всё из этого файла и вставьте данный код, где <path to field dir> — полный путь к папке с полями:
{
"version": "2.0.0",
	"tasks": [ {
		"label": "Run TRIK 2D model",
		"type": "shell",
		"command": "/home/admin/TRIKStudio/run_2d_model.sh" <path to fields dir> script.js",
		"windows": {
			"command": "D:\\TRIKStudio\\run_2d_model.cmd  <path to fields dir> script.js"
		},
		"group": "test",
		"presentation": {
			"reveal": "always",
			"panel": "new"
		}
	}]
}
6
В зависимости от вашей операционной системы отредактируйте tasks.json:

  • Для Linux необходимо в строке соответствующей полю "command" указать путь к отредактированному run_2d_model.sh и третьим аргументом указать файл вашего исходного кода. Данный файл должен находится в папке, которую мы открыли с помощью VSCode. Например:
    "command": "/home/admin/TRIKStudio/run_2d_model.sh /home/admin/fields/ script.js"

  • Для Windows необходимо в строке соответствующей полю "windows": { "command" указать путь к отредактированному run_2d_model.cmd и третьим аргументом указать файл вашего исходного кода. Данный файл должен находится в папке, которую мы открыли с помощью VSCode. Например:
    "command": "D:\\TRIKStudio\\run_2d_model.cmd D:\\Users\\Admin\\fields script.js"
7
Сохраните файл tasks.json.
8
Теперь при нажатии Terminal → Run Task в выпадающем меню выбираем Run TRIK 2D model, чтобы запустить ваш JavaScript-код, или соответствующую комбинацию клавиш (Ctrl+Shift+B).